Авторизируйтесь,
чтобы продолжить
Некоторые функции доступны только зарегистрированным пользователям
Неправильный логин или пароль

Внимание! Теперь для входа на форум необходимо вводить единый пароль регистрации сервисов sibnet.ru!

Здравствуйте, гость ( Вход | Регистрация )



71 страниц V « < 69 70 71  
Ответить в эту темуОткрыть новую тему
> ЧаВо по Pascal/Delphi, Спрашивайте, не стесняйтесь.
mephisto
сообщение 7.6.2008, 21:31
Сообщение #1 (закреплено)


ортодоксальный линуксоид
Group Icon


Группа: VIP
Сообщений: 7 723
Регистрация: 17.11.2007
Из: столицы вашей родины
Пользователь №: 10 849



Тема пока пустая, так что не стесняйтесь задавать вопросы. Еще лучше, если к вопросам будет прилагаться ответ wink.gif

Куратором темы назначается ??????? (место вакантно biggrin.gif)
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения

> ЧаВо по Pascal/Delphi, Спрашивайте, не стесняйтесь.
Nyasha
сообщение 16.11.2013, 18:17
Сообщение #1401


МЕГА флудер
Group Icon


Группа: Пользователи
Сообщений: 1 066
Регистрация: 1.7.2010
Пользователь №: 275 731



Репутация:   20  


Я бы предложил написать это в правильной теме, но для этого еще предстоит найти правильный раздел.

К данному вопрос отношения не имеет.

Сообщение отредактировал Nyasha - 16.11.2013, 18:23
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
tyshka
сообщение 26.11.2013, 17:27
Сообщение #1402


Молчун
Group Icon


Группа: Пользователи
Сообщений: 44
Регистрация: 11.2.2009
Пользователь №: 82 078



Репутация:   0  


Помогите с лабой,срочно надо unsure.gif
1. Определите значение целочисленной переменной S после выполнения операторов:
a) S:=128
нц для i от 1 до 4
S:=div(S,2)
кц
cool.gif S:=1; a:=1
нц для i от 1 до 3
S:=S+i*(i+1)*a
a:=a+2
кц
c) S:=1; a:=1
нц для i от 1 до 3
S := S+i
нц для j oт 2 до 3
S := S+j
кц
кц
d) S:=0
нц для i от 1 до 2
нц для j от 2 до 3
S:=S+i+j
кц
кц
e) нц для i от 1 до 3
S:=0
нц для j от 2 до 3
S:=S+i+j
кц
кц
f) нц для i от 1 до 2
S := 0
нц для j oт 2 до 3
нц для k oт 1 до 2
S := S+i+j+k
кц
кц
кц
2. Составьте алгоритм решения задач разветвляющейся структуры и в виде блок-схем и в виде псевдокода:
a) определить, является ли треугольник с заданными сторонами a, b, c равнобедренным;
cool.gif определить количество положительных чисел среди заданных чисел a, b и c;
c) меньшее из двух заданных неравных чисел увеличить вдвое, а большее оставить без изменения;
d) числа a и b — катеты одного прямоугольного треугольника, а c и d — другого; определить, являются ли эти треугольники подобными;
e) даны три точки на плоскости; определить, какая из них ближе к началу координат;
f) определить, принадлежит ли заданная точка (x, y) плоской фигуре, являющейся кольцом с центром в начале координат, с внутренним радиусом r1 и внешним радиусом r2 ;
g) упорядочить по возрастанию последовательность трех чисел a, b и c.
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Segate
сообщение 30.11.2013, 17:12
Сообщение #1403


:)
Group Icon


Группа: Sibnet-club
Сообщений: 1 677
Регистрация: 9.1.2008
Из: Новосибирск
Пользователь №: 16 184



Репутация:   171  


у меня такая проблема:
в delphi мультимедийный таймер срабатывает каждые 2 милисекунды:
Код

function timeSetEnet(uDelay, uResolution: UINT;
                     IpTimeProc:Pointer;
                     dwUser: DWORD;
                     fuEvent: UINT): UINT;
    stdcall;
    external 'winmm.dll';

function timeKillEvent(uID: UINT): UINT; stdcall; external 'winmm.dll';

procedure TimeProc(uID, uMsg: UINT; dwUser, dwi, dw2: DWORD); stdcall;
begin
TCNT:=TCNT+1;
if TCNT=count*500 then
    begin
        Form1.BComPort1.WriteStr('a');
        Form1.image1.Picture:=nil;
        Form1.axes;
        Form1.image1.Canvas.MoveTo( sc, Form1.image1.Height div 2);
        Form1.BComPort1.ClearBuffer(true,true);
        TCNT:= 0;
        Form1.BComPort1.WriteStr('b');
    end;
end;


запуск таймера происходит строкой ueventid := timesetevent(2,0,@TimeProc,0,1);
процедура Form1.axes; рисует в image1 оси (типа график). дак вот когда эта функция вызывается в процедуре срабатывания мультимедийного таймера, эти оси не рисуются, какбудто неуспевают (иногда бывает пару полос нарисует, а иногда воабще ничего). а если вызвать то, что в условии if TCNT=count*500 then например по нажатию на кнопку, то все хорошо рисует. в чем дело? может есть какие-то нюансы с этим таймером или еще что-то, что я не учел?

Сообщение отредактировал Segate - 30.11.2013, 17:31
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
HiSER
сообщение 1.12.2013, 8:50
Сообщение #1404


Бородатый
Group Icon


Группа: Пользователи
Сообщений: 517
Регистрация: 24.9.2007
Из: Барнаул
Пользователь №: 6 410



Репутация:   37  


Видимо проблема в условии (if TCNT=count*500 then)
Для чего оно?
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Segate
сообщение 1.12.2013, 11:14
Сообщение #1405


:)
Group Icon


Группа: Sibnet-club
Сообщений: 1 677
Регистрация: 9.1.2008
Из: Новосибирск
Пользователь №: 16 184



Репутация:   171  


Цитата(HiSER @ 1.12.2013, 8:50) *

Видимо проблема в условии (if TCNT=count*500 then)
Для чего оно?

нужно чтоб тот код выполнялся каждые несколько секунд (когда таймер запущен count не изменяется). при этом использовать стандартный таймер нет возможности, потомучто значение TCNT с точностью до 2 милисекунд используется еще в одном месте, но там все равботает.
но суть в том, что код в этом условии, он выполняется, но какбудто неполностью, судя по изображению в image1 из функции axes выполняется только несколько первых строк
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Segate
сообщение 1.12.2013, 12:38
Сообщение #1406


:)
Group Icon


Группа: Sibnet-club
Сообщений: 1 677
Регистрация: 9.1.2008
Из: Новосибирск
Пользователь №: 16 184



Репутация:   171  


и вот че интересно:
я попробовал в функции Form1.axes рисовать не в image а на форме. в таком случае почемуто работает, но мне нужно именно в image.
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
HiSER
сообщение 1.12.2013, 14:18
Сообщение #1407


Бородатый
Group Icon


Группа: Пользователи
Сообщений: 517
Регистрация: 24.9.2007
Из: Барнаул
Пользователь №: 6 410



Репутация:   37  


Можно же использовать два таймера.
Попробуй увеличить интервал.
Собака могла зарыться и в другом месте, полный код нужен и хотя бы вкратце, что должно происходить.
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
MotoArhangel
сообщение 4.1.2014, 17:06
Сообщение #1408


- 夜狼 -
Group Icon


Группа: GNU/Linux
Сообщений: 1 218
Регистрация: 24.9.2009
Из: Алтай =)
Пользователь №: 141 745



я вот все не могу понять, почему все думают что 7 версия самая лучшая.
какое первоначальное значение переменной tcnt?
с какой целью используете таймер?


» Спасибо сказали: «
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Nyashka-yaoishik
сообщение 12.1.2014, 17:53
Сообщение #1409


Молчун
Group Icon


Группа: Пользователи
Сообщений: 1
Регистрация: 12.1.2014
Пользователь №: 505 244



Репутация:   0  


Привет, помогите, пожалуйста. Как сделать для чата проверку имен? Чтобы допустим один пользователь не мог задать имя, которое уже используется...
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
mephisto
сообщение 12.1.2014, 18:00
Сообщение #1410


ортодоксальный линуксоид
Group Icon


Группа: VIP
Сообщений: 7 723
Регистрация: 17.11.2007
Из: столицы вашей родины
Пользователь №: 10 849



Цитата(Nyashka-yaoishik @ 12.1.2014, 16:53) *

Привет, помогите, пожалуйста. Как сделать для чата проверку имен? Чтобы допустим один пользователь не мог задать имя, которое уже используется...

Ну берешь и проверяешь, если имя используется — просишь взять другое.
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Wi-Fi
сообщение 18.1.2014, 10:29
Сообщение #1411


Поддерживает разговор
Group Icon


Группа: Пользователи
Сообщений: 207
Регистрация: 28.2.2008
Пользователь №: 22 666



Репутация:   21  


Цитата(MotoArhangel @ 4.1.2014, 16:06) *

я вот все не могу понять, почему все думают что 7 версия самая лучшая.
какое первоначальное значение переменной tcnt?
с какой целью используете таймер?

А какая версия по вашему лучшая, в чем ее плюсы?
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
***kent***
сообщение 9.10.2014, 2:06
Сообщение #1412


Флудерастъ
Group Icon


Группа: Sibnet-club
Сообщений: 1 243
Регистрация: 15.11.2007
Пользователь №: 10 627



Репутация:   -16  


Подскажите что нибудь (библиотеку, компонент, модуль) чтобы можно было простенько буквально в пару строк зашифровать небольшое сообщение каким нибудь более менее криптостойким алгоритмом (des,3des, rsa,гост), ну и расшифровать очевидно.
Хотя сам сомневаюсь что такое возможно в пару строк biggrin.gif
p.s. rad studio xe7.
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
shouhei
сообщение 9.10.2014, 10:55
Сообщение #1413


Himmelsstürmer
Group Icon


Группа: Супермодераторы
Сообщений: 33 420
Регистрация: 2.4.2008
Из: Caught somewhere in time
Пользователь №: 27 739



Репутация:   1415  


Вот, например


» Спасибо сказали: «
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения

71 страниц V « < 69 70 71
Ответить в эту темуОткрыть новую тему
1 чел. просматривают этот форум (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

Текстовая версия Сейчас: 18.11.2019, 5:53
Редакция: (383) 347-86-84

Техподдержка: (383) 347-22-44
help.sibnet.ru
Размещение рекламы:
тел: (383) 347-06-78, 347-10-50

Правила использования материалов