КАРТА САЙТА
Sibnet.ru
Sibnet.ru

Sibnet.ru — это информационно-развлекательный интернет-проект, ориентированный на широкий круг Сибирского региона.
По данным Rambler Top100, Sibnet.ru является самым популярным порталом в Сибири.

Контакты:
АО "Ринет"
ОГРН 1025402475856
г. Новосибирск, ул. Якушева, д. 37, 3 этаж
отдел рекламы:
(383) 347-10-50, 347-06-78, 347-22-11, 347-03-97

Редакция: (383) 347-86-84

Техподдержка: (383) 347-22-44
help.sibnet.ru

Внимание! Теперь для входа на форум необходимо вводить единый пароль регистрации сервисов sibnet.ru!

Здравствуйте, гость ( Вход | Регистрация )



 
Ответить в эту темуОткрыть новую тему
> Обновление Debian, проблемы
broun
сообщение 4.12.2016, 12:59
Сообщение #1


Молчун
Group Icon


Группа: Пользователи
Сообщений: 75
Регистрация: 18.4.2013
Пользователь №: 484 176



Репутация:   0  


Господа, прошу, пожалуйста консультации.

В общем, несколько месяцев назад установил debian 8.2
Поигрался с месяцок, потом на несколько месяцев забросил.
Вернулся.
apt-get dist-upgrade

Загрузка обновлений прошла. Версия 8.6

Для загрузки обновлений использовал следующие репозитории
sources.list
» Спойлер (нажмите, чтобы прочесть) «


Потом узнал, что есть такой репозиторий
Код
deb http://mirror.yandex.ru/debian]http://mirror.yandex.ru/debian stretch main contrib


А там насчитало мне около 2 ГБ обновлений.

Я их запустил. Всю ночь закачивалось.
Утром смотрю вроде бы закачка завершена.

Теперь осталось только нажать "q" и пойдет установка.

Прокрутка работает, а на "q" не реагирует.
Ну я вышел из консоли и все загрузки пропали.


Вопрос:
Что это может быть за фигня такая?


Спасибо.

А еще забыл.

Потом теже обновления (на 2гб) выскочили в качестве уведомления в графическом интерфейсе.

Там я их запустил, но система выдала. что имеется туча нереализованных {или как-то так} зависимостей, т.е. нет кучи каких-то пакетов.

Сообщение отредактировал broun - 4.12.2016, 13:00
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Ronnie-R10R
сообщение 4.12.2016, 15:28
Сообщение #2


No Pain, No Gain
Group Icon


Группа: Активист Видео
Сообщений: 1 150
Регистрация: 30.12.2007
Пользователь №: 15 142



Репутация:   36  


Попробуйте написать в группу вк Debian https://vk.com/debiangroup
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
broun
сообщение 25.12.2016, 12:45
Сообщение #3


Молчун
Group Icon


Группа: Пользователи
Сообщений: 75
Регистрация: 18.4.2013
Пользователь №: 484 176



Репутация:   0  


Не буду создавать новую тему ради этого.

Товарищи, прошу, пожалуйста, консультации.

В общем, решил установить иксы и среду гном (в минимальном исполнении).
Дополнительно поставил
gnome-shell
gnome-tweak-tool
dconf-editor

Начал настраивать.
А нэт. не получается.
gnome-tweak-tool
dconf-editor
запускаются, притом, запускаю их из терминала под рутом, но все равно прав нет.
Зайти в иксы под рутом не могу.
---------------
Попробовал через консоль под рутом выполнить команду startx
Запускаются иксы вроде бы под рутом, но другая оболочка (тот же гном, но в другом исполнении).
Там я настраиваю всё, что хочу, да только мне необходимо выполнить настройки в другом графическом режиме.
---------

Вот и мучаюсь - как это сделать?

- либо обойти ограничения обычного пользователя
- либо зайти под рутом
- либо сделать так, что бы команда startx запускала нужную мне графическую среду
- что-то еще

Помогите, пожалуйста.

Спасибо.

Сообщение отредактировал broun - 25.12.2016, 12:46
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
broun
сообщение 25.12.2016, 16:13
Сообщение #4


Молчун
Group Icon


Группа: Пользователи
Сообщений: 75
Регистрация: 18.4.2013
Пользователь №: 484 176



Репутация:   0  


В общем, установив вот эти наборы:
x-window-system
gdm3
gnome-panel
gnome-terminal
dconf-editor
gnome-tweak-tool
gnome-shell-extensions

Я получил (при загрузке) иксов выбор... из чего?


1. GNOME
2. Классический GNOME
3. Классический GNOME
4. GNOME на Wayland

0. Системный по умолчанию = 1. GNOME

При том, часть из сред после моих действий по изменению настроек шелла получили эти настройки, а часть - нет.

Нафига в списке одни и теже среды (гном), только сбоку?

Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
chaldon
сообщение 26.12.2016, 9:22
Сообщение #5


Омский
Group Icon


Группа: Омичи
Сообщений: 1 863
Регистрация: 24.8.2008
Из: город Омск
Пользователь №: 46 208



broun
Задай вопрос тут: https://debianforum.ru/
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
broun
сообщение 26.12.2016, 23:51
Сообщение #6


Молчун
Group Icon


Группа: Пользователи
Сообщений: 75
Регистрация: 18.4.2013
Пользователь №: 484 176



Репутация:   0  


Расскажу продолжение.

1. Под одним из вариантов выбора между гномом и гномиком ( biggrin.gif ), один вполне успешно работал с настройкой шелла и прочих настроек под юзером.
2. И начал я его настраивать, т.е. начал на него темы навешивать и смотреть.
3. И вот навешав очередную тему уронил GUI
4. Мыкался тыкался и понял, что из представленного выбора мне теперь доступна только одна среда, там, где не было возможности настроить шелл.
5. apt-get autoremove gnome*
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
broun
сообщение 13.1.2017, 20:00
Сообщение #7


Молчун
Group Icon


Группа: Пользователи
Сообщений: 75
Регистрация: 18.4.2013
Пользователь №: 484 176



Репутация:   0  


Товарищи.

Продолжая свои попытки понять зачем Володька сбрил усы как устроен мир линукс пришел к такой программе как mysql - СУрБД.
Первое, что я сделал:
Это зашел в википедию и набрал в поиске "mysql"
И посмотрел версию
5.7.17 (12 декабря 2016)
Прочитав чуть дальше заголовка увидел фразу:
Версия MySQL 5.7.8 адаптирована для Debian 8 и Ubuntu 15.04.
И первый вопрос который у меня возник это:
Как так адаптирована, под какие тогда системы создается mysql, если последняя версия 5.7.17, а для одного из популярнейших дистрибутивов линукс адаптирована только 5.7.8?

Следующим действие было:
apt-get install mysql-server
и после установки и настройки нужных пакетов:
mysql -V

mysql Ver 14.14 Distrib 5.5.53, for debian-linux-gnu (x86_64) using readline 6.3

И тогда вопрос звучал уже более просто: что за фигня?
Но подумав, я решил переформулировать:
Почему из репозиториев установилась версия MySQL 5.5.53?

После дальнейших размышлений возник еще дин вопрос:
А насколько вообще критична такая разница в версиях MySQL? Может быть желание установить самую последнюю версию это психология гика-маньяка?


Буду очень благодарен тем, кто выскажит свое мнение по данному вопросу. smile.gif
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
Jek
сообщение 15.1.2017, 11:35
Сообщение #8


     
Group Icon


Группа: Модераторы
Сообщений: 13 232
Регистрация: 27.9.2007
Из: Кемерово >>> Южный WEB: http://irc.k-42.ru IRC: irc.sibnet.ru #iclub
Пользователь №: 6 588



Репутация:   1582  


MySQL - немного не тот софт, который ставится волшебной кнопкой "Сделать всё хорошо". Для начала надо как минимум заглянуть к ним на сайт, посмотреть, какие есть ветки, и определиться, какая из них нужна тебе (или тому софту, который будет её использовать). Может быть, тебе вообще больше подойдёт MariaDB.

А так в репозиториях обычно лежат пакеты mysql[xx]-server. Т.е. если возникла необходимость в ветке 5.7 - тебе нужен пакет mysql57-server.

Сообщение отредактировал Jek - 15.1.2017, 11:36


» Спасибо сказали: «
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
broun
сообщение 20.1.2017, 23:25
Сообщение #9


Молчун
Group Icon


Группа: Пользователи
Сообщений: 75
Регистрация: 18.4.2013
Пользователь №: 484 176



Репутация:   0  


Цитата(Jek @ 15.1.2017, 11:35) *

MySQL - немного не тот софт, который ставится волшебной кнопкой "Сделать всё хорошо". Для начала надо как минимум заглянуть к ним на сайт, посмотреть, какие есть ветки, и определиться, какая из них нужна тебе (или тому софту, который будет её использовать). Может быть, тебе вообще больше подойдёт MariaDB.

А так в репозиториях обычно лежат пакеты mysql[xx]-server. Т.е. если возникла необходимость в ветке 5.7 - тебе нужен пакет mysql57-server.

Я, кстати, немного разобрался в каких ветках какие версии лежат.
Т.е. что касаемо
stable
testing
unstable

MySQL пока оставил в покое.
Т.е. установил те пакеты, что предлагаются из stable ветки.
Пока мне MySQL не нужна. Я просто LAMP с базовыми настройками поднимал.
Сейчас все больше пока apache2 изучаю, точнее сайт хочу поднять, но не шаблонный, а сам. До MySQL еще далеко. biggrin.gif
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения
broun
сообщение 20.1.2017, 23:55
Сообщение #10


Молчун
Group Icon


Группа: Пользователи
Сообщений: 75
Регистрация: 18.4.2013
Пользователь №: 484 176



Репутация:   0  


На самом деле вопрос веток
stable
testing
unstable

Меня в покое не оставляет

Хочу попробовать поставить какую-нибудь софтину хотя бы из ветки testing.

На глаза попался сниффер wireshark.
Решил на нем попробовать.

Но что-то мне результат (промежуточный) не нравится:

1. В sources.list
добавляю строку:
deb http://mirror.yandex.ru/debian/ testing main

2. Создаю файл конфигурации:
/etc/apt/apt.conf
с параметром:
APT::Default-Release "stable";

3. В командной строке запускаю команду:
apt-get update && apt-get -t testing install wireshark

Так он зараза пытается мне кучу всяких пакетов других подвязать:
обновлено 38, установлено 52 новых пакетов, для удаления отмечено 4 пакетов, и 1112 пакетов не обновлено.

При этом wireshark из стабильной ветки устанавливает всего 9 пакетов.


И вот я не поймapt-get -t testing install я подсмотрел на просторах сети Интернет. Она вроде бы как предполагает установку только нужных пакетов из тестового (в данном случае) репозитория, а тут весь набор всего чего только можно: что не так?
2. А насколько вообще опасно обновлять систему из тестовой ветки?
Пользователь в офлайнеКарточка пользователяОтправить личное сообщение
Вернуться в начало страницы
+Ответить с цитированием данного сообщения

Ответить в эту темуОткрыть новую тему
1 чел. просматривают этот форум (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

Текстовая версия Сейчас: 27.7.2017, 14:00
Редакция: (383) 347-86-84

Техподдержка: (383) 347-22-44
help.sibnet.ru
Размещение рекламы:
тел: (383) 347-06-78, 347-10-50

Правила использования материалов